REMINDER: Deprecating old API versions (Q4 2017)


From March 1st, 2017 DataSift will be removing support for it’s deprecated API versions; v1, v1.1 and v1.2.

If you attempt to make an API call to an unsupported API version, you will receive a 410 Gone HTTP response, and the following error message:

{"error": "This API version is no longer available see for details."}

Full details about DataSift’s API changes and deprecation schedule can be found on our API Changelog page.

Update (February 16th, 2017):

We want to notify you that the DataSift API v1.2 disablement date is being extended by three months from March 2017 to June 2017.

Why is DataSift extending the disablement date?
The disablement of API versions 1.2 and earlier, is being undertaken to ensure that our customers have access to the latest features and fixes available only in more recent API versions.

DataSift will be introducing new API features in API v1.5 in March 2017 (details of these features will be announced later), and as such we would like to offer our customers an opportunity to migrate directly to the latest API version, without the need to step through API v1.3 or v1.4 as an intermediary.

What actions do I need to take?
We’d recommend beginning to evaluate how an update to the latest version of your DataSift client library will affect your application. There have been some changes since API v1.2 which you should prepare for, such as the move from identifying a PYLON recording by “hash” to “id”.

Please feel free to reach out to our support team at if you have any questions regarding the migration or upcoming changes.

Update (May 15th, 2017):

We will be extending the disablement date into Q4 of 2017 or later. We will provide firm dates closer to the time, giving at least two months notice before we drop support for these older API versions.
If you are just getting started with DataSift, we encourage you to take advantage of our latest API version.

Update (September 29th, 2017):

The date of Wednesday November 29th, 2017 has been set to disable API versions 1.2 and earlier.