Java library -- Can't start consuming (even in the examples)


#1

Hi I’m trying to use the datasift java client library for a small project with some troubles. Apparently when I try to consume a Stream using http connections (or any other type of connections at this point), it keeps consuming with no exception being rised or event being launched. At first I thought it was the application I’ve made and tried to view and run the examples, finding the exact same problem.

In my account it keeps draining my money while the consumer is consuming, even though I don’t receive any interaction events at all.

I can’t put more emphasis on the fact that the examples aren’t working for me. The code I’m trying to write is similar to the example in StreamUsage.java with a csdl = “interaction.type == “twitter” and (interaction.content contains “music”)”;

I just downloaded the lastest version and tried again with the same result.

Anyone knows why this could be happining?


#2

I’ve been debugging a little bit more, and I found that the HttpThread is only receiving ticks from the api, no interactions at all.


#3

It sounds like you need to turn on your Twitter Data Source